Edge Impulse CLI Installation Difficulties


I am currently trying to learn ML for the first time through Coursera’s free course: Embedded Machine Learning. I am currently having extreme difficulties trying to install the Edge CLI that is needed for the course and to generally use Edge Impulse on my Arduino Nano 33 BLE Sense Rev 2. When I try to use the npm install -g edge-impulse-cli --force command, I get a lot of errors in the attached image. I have tried the standard troubleshooting techniques to fix this such as uninstalling Node.js and npm and then reinstalling, but still no dice. I would appreciate if someone could guide me to the right path to getting to use my device with Edge Impulse as I would like to start practicing with these new concepts to me.


Hi @npbrad,

You will need to uninstall node.js and try again. Before installing node.js and the edge-impulse-cli, make sure that you:

  • Have Visual Studio installed. I found that version 2019 worked for me. Note that Visual Studio is not the same as VS Code!
  • Install the Additional Node.js tools (called Tools for Native Modules on newer versions) when prompted while installing node.js.

Please refer to the following posts for additional help: