Issue building WebUSB firmware on Nicla Voice in Arduino-CLI

There appears to be an issue related to the mbed core and its association with the .bat file or an outdated association with the newer cores. Is there a specific board and version to use?

Scouring the forum I have found a few others with similar issues some time ago and the solve was .bat file edits or using the correct version of Mbed core, though the one referred to doesn’t exist anymore. I did try both to no avail.

As per GitHub - edgeimpulse/firmware-arduino-nicla-voice: Repository for the Arduino Nicla Voice I am running 0.21.0. Arduino CLI is working properly. Using Win10. In the correct directory.

Tried the “DEPRECATED” Mbed library 1.3.1 which I assumed to be the old version mentioned in other threads and got:

Error during build: Platform ‘arduino:mbed_nicla’ not found: platform not installed
Try running arduino-cli core install arduino:mbed_nicla

I then installed “Arduino Mbed OS Nicla Boards” 4.1.3 and get:

Error during build: exec: “/bin/arm-none-eabi-g++”: file does not exist

(running the suggested command above by the CLI just tells me its already installed)

I’m no expert here, so its entirely possible its an ID10T error. Or I am not sure if there is an issue in the files from Github either. Appreciate the help!

Additional issue and solution (unless I missed something) - The .bat file calls for “firmware-arduino-nicla-voice-main.ino” but only a “firmware-arduino-nicla-voice.ino” exists in the directory. Changed the name and it appears to be working until I hit the Mbed issue. Error I saw below;

Error during build: Can’t open sketch: no valid sketch found in C:\Users\USR\Downloads\firmware-arduino-nicla-voice-main\firmware-arduino-nicla-voice-main: missing C:\Users\USR\Downloads\firmware-arduino-nicla-voice-main\firmware-arduino-nicla-voice-main\firmware-arduino-nicla-voice-main.ino

Hi @Mwas,

Apologies for the confusion–could you provide us with some context around what you’re trying to do? Are you trying to flash one of the pre-compiled firmware ( or to the Nicla Voice boards (as shown in this guide: Arduino Nicla Voice | Edge Impulse Documentation)?

Sorry about that - I see I may have missed some relevant context for my question in the post.

Yes, I am trying to install the firmware (voice) required for the WebUSB interface with edge impulse. I have tried many times unsuccessfully to install the edge impulse CLI so I am exploring this workaround.

The guide linked has instructions for mac, I am on a windows machine so have been following the usage guide for windows from the Github repository linked to in that article. My post is regarding issues I am having following those instructions.

They mention to run a .bat file which should automatically handle compliation correctly. However the

./arduino-win-build.bat --build

throws errors:

Error during build: exec: “/bin/arm-none-eabi-g++”: file does not exist

Something is not playing together well but I am at a loss as to what.