Importing data to edge impulse

When i try uploading data from csv to edge impulse its not allowing me to add more rows on CSV .

Screnshoot the issue so that we can understand it well

Hello @Rishab96 ,

Can you make sure to add a constant timestamp increase?
Feel free to share the first top rows of your CSV file so I can have a better understanding of your issue.



Thanks louis for support . But i found the why the error occured and was able to find the solution for it.

This was the kind of data that i was uploading . Why edge impulse does not support more than two rows in a csv ??

Hello @Rishab96,

You can have a look at Importing CSV data - Edge Impulse API

Edge Impulse requires CSV data to be stored in a particular format. You’ll need to create one CSV file per sample (e.g. a machine with a fault state). The first row should be a header describing the sensor axes, and each row should be a single reading at a particular time. For multi-axis, time-series data, the first column must be a timestamp. For example, this is data from an accelerometer:








For a single, multi-axis reading (i.e. something that is not time-series data), you can omit the timestamp. Note that you must have 1 header row and only 1 data row. This is an example from a single, triple-axis accelerometer:


I tried import the csv in above format where timestamp is there in first column but again getting the error this way : For CSV files without a timestamp column, need exactly one line with values (but found 4)

Hello @Rishab96,

You need to put “timestamp” instead of “Timestamp”, will ask our core engineers to add this exception, you’re not the only one to encounter this issue.

However, I can see that your timestamp increase is not constant which will lead to another issue.
Make sure to have a constant frequency before uploading your CSV.



When i upload the csv with multiple rows it is accepting such file but the length of the sample on edge impulse is zero .

Length of the sample is zero .

Hello @Rishab96,

The timestamp is in millisecond, that is probably why. We round the length in the studio for the display.



@louis Thanks fro your support .

@louis One issue i facing is with split the data sets .Actually i am not able to split the data sets that i have captured.

Hello @Rishab96,

Can you share your project ID please so I can see what goes wrong?
Have you clicked on “+Add Segment”?



@louis project ID: 139393


Not exactly sure what you are trying to achieve with your project.
The split option is useful when you collect let’s say 30 sec of keywords and you want to extract each keyword individually.

For you project it did not recognized any patterns but you can add your segments manually.