ERR: Failed to run DSP process (-1004)


When I run the example-standalone-inferencing, I get the following error: ERR: Failed to run DSP process (-1004). I’ve had this working before with another project, but when using the Spectrogram block, it won’t run.

Do I need to change something in my Spectrogram block or in the C++ code?

After looking a bit further, I found this link: EIDSP_MATRIX_SIZE_MISMATCH on Teensy 4.1, which looked like my error. So after trying the workaround, I got this error message from the Studio:


Can you upload your cpp project?

I use the example standalone inferencing.

Right, but to fully help you I’ll also need the folders exported from Edge Impulse… edge-impulse-sdk, model-metadata, etc :slight_smile:

You can download the files here.

Thanks, I’ll take a look when I get a chance

Hi @Jurg,

I opened an issue to support parallel spectrogram blocks, we’ll keep you posted.


1 Like

@Jurg I missed Aurelian’s reply earlier, looks like you guys got to the bottom of things.

Hi @aurel,

May I ask if there is any update on this?


@Jurg this has now been released.

Hello @janjongboom,

This feature indeed works! Thanks!

I only have one problem. When I go to “Model testing”, the output stays on Attached to job xxxx....

@Jurg Which of these projects is this for? There are a bunch under your account :slight_smile:

@janjongboom For ESP32_ADS1015 v2, project id 40417.

Hi @Jurg sorry that it took a while. In your dataset you have sample testing.json.28r506jk which only has piezo_right axis, not piezo_left. If you remove it this will succeed.

The error was swallowed, and thus the job was not marked as failed (with error message), we’ll push a fix in the next release.

Ah thanks! That indeed solved my problem!

1 Like