Edge-impulse-linux problem with camera

| Coral Dev Board | camera Webcam (USB) |
I can run


and when I do it prompts for credentials (ok), microphone (sees USB-Audio - Webcam ok)

[SER] Using microphone hw:2,0

then it appears to hang. If I start with --disable-camera it starts fine and appears as a device in the portal. I’m thinking it is getting stuck at the camera find. NB It does this with or without the USB webcam connected. I’m wondering if it is stuck looking for the CSI connector on the board (without a camera connected). Is there anyway to explicitly specify camera before run? Or maybe turn off devices it attempts to probe?

I decided to go for brute force, so…

sudo rm /dev/video0

Then edge-impulse-linux worked first time with camera Webcam detected on /dev/video1. NB It doesn’t persist after reboot, which is actually ok for now.

1 Like

Hi @gavin67890,

Glad to hear you found a workaround. Could you try some of the following troubleshooting techniques to see if they work? Also, what USB webcam are you using (as not all are supported…Linux drivers might not work well for them)?

I think it’s the setup of the on-board camera port - it’s present but without a camera connected it causes the initial probe to hang. I went for a UVC camera with OV3660 sensor (HBVCAM-3M2111) to match the sensor on my MCU board. It actually worked really well and fine connected to MacBook, etc. as well.

1 Like