Cannot detect camera

So I ran into a problem when I try to deploy my AI model onto a Raspberry Pi. I tried to use the CLI commands to deploy and when I enter edge-impulse-linux in the Raspberry Pi terminal, it just says cannot find any camera. When I do lsusb the camera I connected to shows up, and when I use the edge impulse browser and launch the model on the browser, it uses the connected camera and does live classification. So I do not really know whether it is the connection, or the software issue or my camera model is just not compatible

P.S. The camera I am using is the RealSense2 L515 LiDAR Camera from Intel

Hi @JordanJong

Can you paste the output of how the camera is listed here please? It may not be presenting as expected, and you may need to modify our code to detect it.



Sorry for the late reply, I was away from office for a few days.

Failed to initialize linux tool Error: Cannot find any webcams, run this command with --disable-camera to skip selection
    at /usr/lib/node_modules/edge-impulse-linux/build/cli/linux/linux.js:437:23

But this is what the output shows when I enter edge-impulse-linux on the terminal of the Raspberry Pi. Could it also be that I did not install the Real Sense Library? Thanks for your reply!

That could be the problem:

Try installing their libs and see, I dont know their kit at all, try installing with apt or from their repo:

sudo apt-get update && sudo apt-get upgrade
sudo apt-get install librealsense2-dkms
sudo apt-get install librealsense2-utils