Edge-impulse-daemon: problems with bindings

Dear All

I’m taking an embedded ML course on Coursera that will use the Nano BLE Sense for practical work and the software platform chosen is edgeimpulse.

I’ve installed Visual Studio, python3, node.js and the arduino-cli, I’ve successfully flashed the edge-impulse firmware I appear to have successfully used npm to install edge-impulse-cli. However when I run edge-impulse-daemon I get “throw err” and “could not find bindings-file”. I’ve tried the uninstalling and re-installing as advised in the post Edge-impulse-daemon -Error but without success - in fact over a couple of days I have uninstalled and reinstalled pretty-much everything.

I am not sure it is relevant but I’m using Windows 10 and “C:\Users[user]\AppData\Roaming\npm\node_modules\edge-impulse-cli\node_modules@serialport\bindings” does not have any of the subdirectories edge-impulse-daemon says it’s looked in for bindings ie “build”, “out”, “Debug”, “Release”, “compiled” etc. The only sub-directories it has are lib, node-modules and src.

Advice welcome. I can’t help feeling with all installing and uninstalling I’ve overlooked something simple - please don’t assume any degree of sophistication, nothing is too obvious.

Hi @LV55, so sorry for the issues you have been experiencing.

Since you’ve uninstalled and re-installed so many times, do you mind trying to install using the Windows installation script I created for creating an Edge Impulse CLI environment? Here’s the instructions: https://github.com/edgeimpulse/ei-install-scripts

Let me know how this goes!


Thanks, I’ll give it a go - do I need to uninstall and delete old files and directories first?

Hi @LV55,

Uninstall the CLI first: npm uninstall edge-impulse-cli and delete the C:\Users[user]\AppData\Roaming\npm\node_modules\edge-impulse-cli\ folder in case it is still present.
If you still experience issues, can you share/paste the installation logs here?


1 Like