Continual ‘Exception: Could not find the file’ error

I’m following this tutorial on EdgeImpulse regarding OpenMV image detection ( Everything worked like a charm until this step ( ). I followed the “Deploying your impulse as an OpenMV firmware” recommended method - downloaded the .zip, loaded the firmware for the correct model after download, erased internal file system, blue LED blinked, etc. When I ran the provided, however, a “Could not find the file” error happened:

I followed the tutorial to the letter. Does anyone what’s causing this issue and how to solve it? Much appreciated!

Hi @anorakx,

Can you try deploying the impulse as an OpenMV library to see if that will work? OpenMV - Edge Impulse Documentation

I have the same problem. I even tried to copy the labels.txt file and the .tflite file on the storage device and got a memory error

Hi @dpgraham2012,

What version of the OpenMV do you have, and what is your project ID? In my experience, the OpenMV H7 (v1) ran out of memory very quickly for anything beyond simple image classification. Even on simple FOMO projects, I would receive “out of memory” errors.

I’m using OpenMV H7 cam with 140 images dataset
Project ID: Don Graham/Image
I included a SD memory card as well.
Doing image classification for 2 objects

Hello @dpgraham2012,

Just to make sure, did you upload the edge_impulse_firmware_openmv4.bin firmware if you use the OpenMV H7 cam?

I had the same issue in the past and I noticed that I was just loading the wrong firmware, I added a naming matching in our docs.



Here is pic of the latest error I get from edge impulse code

Where in OpenMV do you upload that firmware: