Bug: Developer Versioning Not Storing Data

Versioning was introduced Sept 2020

@jenny @louis @shawn_edgeimpulse

As far as I remember versioning worked great, allows you to make a new model based on an old version. Recently I wanted to keep my old model and make a duplicate, so I made a verison and it worked fine, but did not save the data. No problem for me since I had the original; I exported then imported the data, but that doesn’t seem to be correct ability for versioning. The verison should save the data as well as the model structure.

Today I loaded an old: sound, classify and fomo model and made a version and then restored the version and for each each case in “developer” mode the new version did not have any data!

Can someone check my results, and is this correct for the developer mode. Makes sense that full versioning with data is only a paid ability, but it should mention that somewhere.

Hello Jeremy,

This should be available for all user profiles (developer and enterprise).
Can you point out which project has this issue please?



Possibly the issue only happens for me. That is why it would be nice if someone could test it.

I took a project I have already shared with you # 94195

and made a version of it. I then tried to restore the version both as a developer or in enterprise #105828 and both did not copy over the data. Louis, if you load #105828 which I have shared with you, does it have any data?


Hello @Rocksetta,

That’s indeed a bug. I’m creating an internal ticket. I created a version called Edge Impulse Support (Louis) and tried to restore it but I am having the following issue:

It might have something to do with your dataset but not sure. I’ll ask our core engineers to have a look at it. Thanks for reporting it.



1 Like

@louis I think I can add to this issue. Looks like I was doing it wrong. This image helps correct the situation. If I click the store button everything is fine. If I click the creat button I have the issues I was seeing.