Zsh: command not found: edge-impulse-daemon

Hi everyone. I am using a macbook pro m1 and when I’m trying to install edge-impulse-daemon i get the error: zsh: command not found: edge-impulse-daemon.
Previously, I’ve installed node.js and following all the steps of the tutorial. I’ve also tried the solutions of a similar post here, but still get this error. Anyone can help?
Thanks in advance,
Ilias

Hi, have you have uninstalled and reinstalled edge-impulse-cli? with…

npm uninstall -g edge-impulse-cli
npm install -g edge-impulse-cli

If that doesn’t work, you could also try the install scripts here: https://docs.edgeimpulse.com/docs/cli-installation#installation-script

Hi @jenny. I tried uninstall and reinstall edge-impulse-cli but i get this:

added 299 packages, and audited 300 packages in 19s
12 packages are looking for funding
run npm fund for details
10 vulnerabilities (5 moderate, 1 high, 4 critical)

To address issues that do not require attention, run:
npm audit fix

To address all issues possible (including breaking changes), run:
npm audit fix --force

Some issues need review, and may require choosing
a different dependency.

I have the same problem, I’m using Kali Linux.

Hi,

Can you report the value of $PATH?

Another thing, if you followed this tutorial here: https://docs.edgeimpulse.com/docs/cli-installation
Can you replace .profile with .zprofile if zsh is also your login shell. Otherwise you can use your .zshrc to export the PATH as in the tutorial.