Zero padding raw data


I have some doubt about the option to zero pad raw data.

I have checked the option in the time series data block on the web interface.

After the input stage I have implemented a custom processing block, however it seems like this block does not receive 0 padded data.

But zero padding has to be done on feature level (which kind of makes sense) … But why the option is in the input block at all and not in the classifier block ?

Am I missing something here ?

Best Regards

Hi @step22,

What is your window and step size? The 0 padding on the input block is used to pad samples if they are shorter than the window size. If you tell me Project ID, I can take a look at your project to see how you have the impulse configured.


the project id is 66979.

my window size is 600ms and zero padding is checked in the input block.

however e.g. on samaple gesture.31n70eao which is 300 something ms long, my preprocessing function receives exactly those 300 ms not 600ms as I would expect it.

zero padding seems to be applied after the preprocessing … which makes sense … it is just confusing, that the option is in the input block.