Windows OS and MingGW compilation issue

Hi All,

My project directory:

My project zipped link:

when I run mingw32-make I get the following very long error:

/tensorflow/lite/micro/memory_planner/linear_memory_planner.o edge-impulse-sdk/tensorflow/lite/core/api/op_resolver.o edge-impulse-sdk/tensorflow/lite/core/api/error_reporter.o edge-impulse-sdk/tensorflow/lite/core/api/tensor_utils.o edge-impulse-sdk/tensorflow/lite/core/api/flatbuffer_conversions.o edge-impulse-sdk/tensorflow/lite/core/api/common.o -o ./build/app -lm -lstdc++, …) failed.
make (e=87): The parameter is incorrect.
mingw32-make: *** [Makefile:110: app] Error 87
PS I:\example-standalone-inferencing-master>

I am using windows 11 with mingw 8.1 and the path to the compiler/make are properly set. Tried multiple compiler versions and GCC compiler itself.

Any idea what is going wrong?

Hi @electrovortex016,

This error:

mingw32-make: *** [Makefile:110: app] Error 87

Shows that you are running into Windows’ max character limitation (see here for more information). I recommend using WSL instead of MinGW to get around the character limitation.

Hi @shawn_edgeimpulse
Thank you very much for your response and insight. I tried WSL and it worked.
Any idea how to make it work using Windows OS only?

Thanks in advance.

Hi @electrovortex016,

The Windows character limit has been a known limitation for a long time. You might be able to hack the registry to lift the limit, for example, see here: How to change the default 256 character path limitation (MAX_PATH) in Windows 10