Windows CLI error

Hi
When I run edge-impulse-data-forwarder.cmd I get the following error.

C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\node_modules\bindings\bindings.js:135
 throw err;
 ^

Error: Could not locate the bindings file. Tried:
→ C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\node_modules\@serialport\bindings\build\bindings.node
→ C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\node_modules\@serialport\bindings\build\Debug\bindings.node
→ C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\node_modules\@serialport\bindings\build\Release\bindings.node
→ C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\node_modules\@serialport\bindings\out\Debug\bindings.node
→ C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\node_modules\@serialport\bindings\Debug\bindings.node
→ C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\node_modules\@serialport\bindings\out\Release\bindings.node
→ C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\node_modules\@serialport\bindings\Release\bindings.node
→ C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\node_modules\@serialport\bindings\build\default\bindings.node
→ C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\node_modules\@serialport\bindings\compiled\12.16.3\win32\x64\bindings.node
→ C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\node_modules\@serialport\bindings\addon-build\release\install-root\bindings.node
→ C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\node_modules\@serialport\bindings\addon-build\debug\install-root\bindings.node
→ C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\node_modules\@serialport\bindings\addon-build\default\install-root\bindings.node
→ C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\node_modules\@serialport\bindings\lib\binding\node-v72-win32-x64\bindings.node
   at bindings (C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\node_modules\bindings\bindings.js:126:9)
   at Object.<anonymous> (C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\node_modules\@serialport\bindings\lib\win32.js:1:36)
   at Module._compile (internal/modules/cjs/loader.js:1133:30)
   at Object.Module._extensions..js (internal/modules/cjs/loader.js:1153:10)
   at Module.load (internal/modules/cjs/loader.js:977:32)
   at Function.Module._load (internal/modules/cjs/loader.js:877:14)
   at Module.require (internal/modules/cjs/loader.js:1019:19)
   at require (internal/modules/cjs/helpers.js:77:18)
   at Object.<anonymous> (C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\node_modules\@serialport\bindings\lib\index.js:6:22)
   at Module._compile (internal/modules/cjs/loader.js:1133:30) {
 tries: [
   'C:\\Users\\paul\\AppData\\Roaming\\npm\\node_modules\\edge-impulse-cli\\node_modules\\@serialport\\bindings\\build\\bindings.node',
   'C:\\Users\\paul\\AppData\\Roaming\\npm\\node_modules\\edge-impulse-cli\\node_modules\\@serialport\\bindings\\build\\Debug\\bindings.node',
   'C:\\Users\\paul\\AppData\\Roaming\\npm\\node_modules\\edge-impulse-cli\\node_modules\\@serialport\\bindings\\build\\Release\\bindings.node',
   'C:\\Users\\paul\\AppData\\Roaming\\npm\\node_modules\\edge-impulse-cli\\node_modules\\@serialport\\bindings\\out\\Debug\\bindings.node',
   'C:\\Users\\paul\\AppData\\Roaming\\npm\\node_modules\\edge-impulse-cli\\node_modules\\@serialport\\bindings\\Debug\\bindings.node',
   'C:\\Users\\paul\\AppData\\Roaming\\npm\\node_modules\\edge-impulse-cli\\node_modules\\@serialport\\bindings\\out\\Release\\bindings.node',
   'C:\\Users\\paul\\AppData\\Roaming\\npm\\node_modules\\edge-impulse-cli\\node_modules\\@serialport\\bindings\\Release\\bindings.node',
   'C:\\Users\\paul\\AppData\\Roaming\\npm\\node_modules\\edge-impulse-cli\\node_modules\\@serialport\\bindings\\build\\default\\bindings.node',
   'C:\\Users\\paul\\AppData\\Roaming\\npm\\node_modules\\edge-impulse-cli\\node_modules\\@serialport\\bindings\\compiled\\12.16.3\\win32\\x64\\bindings.node',
   'C:\\Users\\paul\\AppData\\Roaming\\npm\\node_modules\\edge-impulse-cli\\node_modules\\@serialport\\bindings\\addon-build\\release\\install-root\\bindings.node',
   'C:\\Users\\paul\\AppData\\Roaming\\npm\\node_modules\\edge-impulse-cli\\node_modules\\@serialport\\bindings\\addon-build\\debug\\install-root\\bindings.node',
   'C:\\Users\\paul\\AppData\\Roaming\\npm\\node_modules\\edge-impulse-cli\\node_modules\\@serialport\\bindings\\addon-build\\default\\install-root\\bindings.node',
   'C:\\Users\\paul\\AppData\\Roaming\\npm\\node_modules\\edge-impulse-cli\\node_modules\\@serialport\\bindings\\lib\\binding\\node-v72-win32-x64\\bindings.node'
 ]
}

Please advise.
I am using windows 10 with
node.exe --version v12.16.3

Hi @paulphilip, what’s the output of the:

npm install edge-impulse-cli -g

command? Looks like an error occured there prior and it cannot locate the bindings for the serialport package.

I followed the instruction as given in https://docs.edgeimpulse.com/docs/cli-installation

npm install edge-impulse-cli -g
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
C:\Users\paul\AppData\Roaming\npm\edge-impulse-uploader -> C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\build\serial-daemon\cli\uploader.js
C:\Users\paul\AppData\Roaming\npm\edge-impulse-data-forwarder -> C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\build\serial-daemon\cli\data-forwarder.js
C:\Users\paul\AppData\Roaming\npm\edge-impulse-daemon -> C:\Users\paul\AppData\Roaming\npm\node_modules\edge-impulse-cli\build\serial-daemon\cli\daemon.js
npm WARN tsargs@1.4.0 requires a peer of typescript@^3.1.6 but none is installed. You must install peer dependencies yourself.

+ edge-impulse-cli@1.6.0
updated 1 package in 17.656s

Still I am facing the error

Resolved it by

npm uninstall -g  edge-impulse-cli

and then installing again. Thanks for the support.

1 Like

Thanks for keeping me posted! :rocket:

im facing the same problem

Hi @delphi,

Have you tried running this?

Aurelien