Window 10 install error Edge Impulse CLI

I have issues when installing the CLI. I have gone through many forum threads and follow the suggested solutions. I have tried different version of nodejs (18.18, 20.8 with development tool script included) and python (3.9 and 3.12). This picture is when I tried the install script:

Can someone help me with this problem?

I am getting the exact same error when i try to install the CLI. I’ll keep you posted if I find anything that works to fix the issue.

Hey @ncharlesw1, I change my python version and the issue is resolved. Apparently, distutils is formally marked as deprecated in Python 3.10 and onward, and in Python 3.12, it has been removed. Code that imports distutils will no longer work from Python 3.12.

So I uninstall my Python 3.12 in control panel and delete the enviroment varible path for Python 3.12 (forgot to do it last time). Then I just install Python 3.9.13 and it works great.

I hope this info will get your project started.

1 Like

@khanhle325 Nice find about distutils.

My EI CLI is running under Python v.3.11 so going back to v3.9 may not be needed.