Why am I getting this error when I try connecting Photon 2 to WebUSB

I have latest firmware updated. Does Edge Impulse not support Photon 2?

Hi @kanchan_pathak,

The error message seems to indicate that you have another application open on your computer that is currently connected to the Photon 2. Try unplugging the P2, plugging it back in, and reconnecting through the Edge Impulse Studio again. I tested my P2 with Edge Impulse Studio Web USB last week and it worked.

1 Like

Hi @kanchan_pathak

The port may be in use already, have you tried using a private or alternative browser?

Are you on Linux Windows or OSX?
Device Recognition:

  • Check if your operating system is recognizing the device. On Windows, you can use Device Manager; on Linux, use the lsusb command; and on macOS, use the System Report.
  • If your device is not recognized by the operating system, WebUSB won’t be able to access it either.
    Enable WebUSB in Browser:
  • In some cases, you might need to enable experimental features in your browser to use WebUSB. In Chrome, you can access experimental features by navigating to chrome://flags/ and enabling any flags related to WebUSB.
    Check WebUSB Compatibility:
    • Ensure that your browser supports WebUSB. Google Chrome and Edge are typically the most compatible with WebUSB.
    • Try using a different browser or updating your current browser to the latest version.
      USB Cable and Port:
    • Try using a different USB cable. Sometimes, the issue might be with the cable itself, especially if it’s not a data cable.
    • Test different USB ports on your computer. Some ports may not support the connection properly, especially if they are USB 3.0 ports and the device is only compatible with USB 2.0.

If these steps dont work please post again and give some detail on the platform OS you are on so we can give some further debugging steps.