Warning: erroneous pipeline: no element "video" when connecting linux virtualbox

I’m using a Ubuntu VirtualBox to test out edgeimpulse for microcontrollers and I have the webcam working in the guest, but when i run edge-impulse-linux --verbose i get the above error.
It finds the camera, it says Using camera ______ starting

Hi @RowanMo,

I tested on my VirtualBox with Ubuntu 18.04, and it seems to be working for me:

? Select a camera (or run this command with --disable-camera to skip selection) 
Logitech BRIO (/dev/video0)
[SER] Using camera Logitech BRIO (/dev/video0) starting...
[GST] Starting gst-launch-1.0 with [

A few things to try:

  • Make sure you can see a captured image from your webcam. I had to install VirtualBox extensions and set up a USB filter to get the feed to show up on Cheese (in Ubuntu).
  • Do you have another Linux (non guest VM) machine to try this on?

I have installed cheese and VLC and both are able to get video input. We do not have another non VM Linux machine to try it on, as this was our test to see if this was feasible for our project. Also, we tried with another Ubuntu VM and got the same error