Value of "length" is out of range

Trying to create a Fail/Ok classification model. At first, I was exceeding the 4Gb limit but was able to cut back to below 4Gb. Then, I ran into another error with " The value of “length” is out of range. It must be <= 5242880. Received 422400000".

My data acquisition consists of a Spectral Analysis block and Audio (MFE) block using data recorded at 48kHz with a window size of 1,100ms and window increase of 15,000ms. My learning block is classification (Keras). I am trying to keep my data within the confines of a free account, so my blocks and sizes are kind of awkward. Any help would be appreciated!

Hi @AlexP,

How did you upload your data?
Your sample data is actually 48 MHz. You’re then selecting 48 kHz for downsampling but this seems to cause some memory issue.
Could you re-upload your data with the good sampling frequency? In the json format, we use interval_ms to set it. For 48 kHz, this should be set to 0.020833…


1 Like

Hello Aurelien,

I fixed the upload issue but quickly ran into another issue. I am not sure what it means.

“Error windowing Downsample error code was not 0, but was null
Downsample error code was not 0, but was null”

window size: 15 ms
window increase: 1000 ms
freq: 48,000 Hz
Zero-pad data: Checked

Strange that it goes through downsampling as the frequency should not change, I’ll look at your proejct.

On the window values though, 15ms is quite small - you may need a larger window to classify data correctly. Also the window increase is usually equal to window size or lower. With this value I think some samples will be dropped from your dataset.


Agreed Aurelien,

Unfortunately, due to only having a free account, I cant make the window size larger or I will start to exceed the 4Gb limit. I do understand that this will cause my model to skip over data, but I don’t have many options so this will have to do.

I could remove some of the source files to condense the data, which would allow me to expand the window size but I have already cut over half of my files out, so that is not ideal.