Using raspberry pi camera

Hey there !!
I am working on an object classification project but I am having trouble with the camera I get the following error: Failed to initialize linux tool Error: Cannot find any webcams
I am using the a raspberry pi camera Rev 1.3
I tried testing the camera by taking a photo and it worked normally
Could you help me please

Hello @PFE_TinyML,

Which Raspberry Pi OS are using?
I had the same issue last week with the latest RPI OS version and I noticed that I had the legacy camera enabled in the raspi-config. I solved it by turning off the legacy camera.

Let me know if that works



1 Like

I also encounter issue with the camera. It is likely I am just doing something wrong but I can’t find any documentation to fix it.

Here’s the details:

  1. I run edge-impulse-linux-runner and everything works great!
  2. To terminte the execution, I hit ctrl+x in the keyboard.
  3. If I try to run edge-impulse-linux-runner again, it can’t find the camera anymore. I have to restart my Rpi. This both happen in RPi Camera and WebCam. I am thinking my step #2 is wrong.
1 Like

Hey @louis
THANK YOU SO MUCH ! It worked !! I’ve been stuck with this problem for 2 days
thank you again.


Hi there,
I m using raspi 4 bull’s eye OS for object detection. but I get the camera(Rev 1.3) error: ‘can not find any web cams’. Same as @PFE_TinyML .
Camera is working normally while capturing the photo but can’t capture images for training and inference when used with edge impulse platform.
Using ‘raspi-config’ I turned off legacy camera still same error is there.
Also I downloaded ‘gstreamer.js’ file and copied it in ‘/usr/lib/node_modules/edge-impulse-linux/build/library/sensors/’
Here it gives Permission Denied error. Can anyone help to resolve this?
Thanks in advance…

How did you turn the legacy camera off? I thought we needed to go to that in the interface option?