Unable to upload edge impulse firmware to Arduino Nano 33 BLE Sense [Solved]

After installing the dependencies (Edge Impulse CLI, Arduino CLI), I was unable to upload the edge impulse firmware to the Arduino board when I selected the flash_windows.bat. Instead, I received this message in the command prompt:

Thanks in advance for any suggestions.


  1. Edge Impulse CLI (node.js V1.4)
  2. Arduino CLI (0.18.0)
  3. Windows 10
  4. Arduino CLI is added at Path (C://arduino-cli)

Hi @Ridzuan,

Can you verify your PATH environment variable? It should contain the Arduino CLI path. You can verify if it works by opening a terminal and run: arduino-cli


Hi @aurel,

Thanks for the reply. The Arduino CLi is detected when prompted in the command prompt:

The board was also connected to the computer with the push button pressed twice. I am wondering if I’ve missed some steps here.


I just noticed that your logs show an error on the where command.

Can you try running it in your terminal: where /q arduino-cli?

I got this message when I run the command:

Hope this gives some hints to the root of the error.

This is strange as the where command is part of Windows OS.

Does it work if you run: C:\Windows\System32\where
If it does work, can you check that your system environment variable contains this System32 directory?

I can run the command as shown below:

However, seems like System32 directory is not available (can’t post the screenshot as only one screenshot is allowed (at least for new user, I presume)).

Incomplete installation, I guess. Which one, I wonder.

Seems the error is gone when I added the directory System32 to the path. However, another error is emerged:

The Arduino Nano 33 BLE can’t be found. Do I need to use the previous version (0.13.X) of Arduino CLI?

Eventually, I managed to load the firmware to the board and the board is now connected to the Edge Impulse:

Thank you @aurel for your time and solution insight… really appreciate it.