Trouble installing CLI tools on MacOS

Hey there I checked a few forums and I’m still struggling to solve this install. I noticed this when I was constantly trying to write “edge-impulse-daemon” in my terminal and never recognizing the command. I’m fairly new to this, so any help would be greatly appreciated.

Hi @loganmay,

Can you please try completely uninstalling and re-installing the CLI with the following commands?

npm uninstall -g edge-impulse-cli
npm install -g edge-impulse-cli

Then, connect a dev board to your computer, and retry the edge-impulse-daemon command.

Let me know how it goes!

Hey @jenny

I tried your commands, I’m still experiencing the same issues.

As well as the edge-impulse daemon command still not being recognized.

Thank you for your support,

Hi @loganmay,

You can force overwritting files after uninstalling the CLI using:

npm install -g edge-impulse-cli --force

Let us know if it works,

Thank you @aurel

Installation was successful. But now connection with my Nano BLE 33 is not being recognized, during the flash_mac.command, this can be seen when I run edge-impulse-daemon it might be because the forced cli download does not recognize my Nano BLE 33 (although it is connected via usb). It outputs:

[SER] Could not find any devices connected over serial port

[SER] Retrying in 5 seconds

@loganmay, can you detect the board if you run arduino-cli board list?
If not it’s most likely an issue with the hardware: you can try switching your USB cable (some cables don’t support data transfer), or you can force the board to booloader mode (do a quick double press on the boards’ switch, LED should fade in and out slowly then).


Hey Aurel,

Sorry for the delay, this is the current error I’m reading. It seems that it does recognize I am using an Arduino Nano 33 BLE but it still cannot get info from the device although I changed the wire. So it looks like the cable is alright.

Hi @loganmay,

Are you running our default firmware? (


Hi @aurel

It started working after I updated the firmware to the latest version! Thank you so much for your help and your patience in answering my questions, I really appreciate it!

Much thanks,