Thingy 91 Edge Impulse Not Working

Hello Everyone wave

Can someone help me with this.

I am trying to connect my Nordic thingy91 to Edge Impulse but I am unable to do.

I have followed all the steps mentioned in this article: Nordic Semi Thingy:91 - Edge Impulse Documentation

Even I have flashed the firmware using external probe but no success.

Thank You!

1 Like

Hi @MukeshSankhla,

Did you try both UART ports that were enumerated? For me, it was the second COM port shown, even though the docs say pick the first one (it might be a Windows vs. Mac thing).

1 Like

Hello Shawn,
Thank you for the response, I have tried both the COM ports but still I am unable to connect.

I am using windows 11.

Thank you!

Hi @MukeshSankhla,

I tried to update my firmware using nRF connect v3.11.1, and I seem to be having the same issue as you now. I have submitted an issue ticket to the dev team: Thanks for pointing this out!

Thank You Shawn!

Big fan of yours, always learning from you videos.

1 Like

I have the same issue tto and caan’t connect to Thingy91

Hey guys! Just subscribed tot his thread as i am facing the same issue on the Thingy:91. Succesfully flashed the firmware.hex in MCUBoot mode but when running the edge-impulse-daemon i get the same timeout problem. I have tried to use the nRF Connect 3.7.1 as stated in the tutorial but in that case the board does not show up in the connected devices list.