Thingy 53: Can't connect with Edge Impulse App after rolling back to Initial Edge Impulse FW

Hi, after building my Edge Impulse project for my Thingy 53 and writing it to the device with the nRF Connect for Desktop - Programmer Tool, I can no longer connect to the Thingy 53 device with the Edge Impulse App. However as I check with the serial terminal connection, I can see that my classification model is working as I run the impulse with AT commands.
As I rolled back to the initial version using the edge_impulse_1.0.0_thingy53_nrf5340.zip from the Nordic Website, the problem persists. I can see the device as “edge impulse” in the Edge Impulse app, however as I tap to it the RGB led turns RED and the connection always times out.
I created a ticket to the Nordic Team as well. If you’d like to take a look at it for the logs and screenshots:

Thank you.

Hi @drselim !
Your problem looks like an issue with CPUNET firmware (Bluetooth core), not with Edge Impulse firmware. However, I recommend getting an external programmer (e.g. nRF5340DK) and trying to perform a full-erase chip and flash from scratch using the firmware from the Nordic website.
Let me know if you have any progress or update on this topic.

Best regards,
Mateusz

1 Like

Hi Mateusz, thanks a lot for your response! I’m planning to do what you suggested. At the moment I have an nRF7002 DK, and I’ll use it as external debugger. However I’m lacking the 10 pin SWD programming cable between the DK and the Thingy and I ordered it. I’ll update the tickets as soon as it arrives and perform what you suggested.

Just to make it clear, I’ll again use the nRF connect desktop’s programmer tool to program the thingy (this time through the nRF7002 DK) and use “nordic-thingy53-full” package from:
Nordic Semi Thingy:53 - Edge Impulse Documentation.
Its readme:
"Thingy53 full firmware

This firmware contains firmware for APP and NET cores. Both firmware consists of bootloader and main firmware.
To flash the firmware, you need an external debug probe. See the following page for detailed instructions on how to flash this firmware:

See Getting Started Guide for more details:

(c) Copyright 2022 Edge Impulse Inc., all rights reserved."

Thank you
Selim

The issue is solved in the programmer app version 3.0.8 in nRF connect for desktop 4.0.1. Now as I write the “edge_impulse_1.0.0_thingy53_nrf5340” from “2023-03-24-precompiled-application-firmware” (Nordic Thingy:53 - Downloads - nordicsemi.com) the Thingy:53 goes back to its original state and I can connect with the Edge Impulse mobile app and collect sensor data.