Stuck on mobile client [loaded wasm module]

hi guys,

I have installed mobile-client on raspberry pi. I have following the instructions, but when I tried to run classifier I got stuck on loaded wasm module.
here is the screenshot

how to fix this?

Hello @desnug1,

I’ve have not played with the mobile client locally, I usually just use the version provided from the studio :slight_smile:

I’ve just been through the code and I’ve seen this line:

I just want to make sure that you can see the .wasm file somewhere locally?

Also feel free to share the console output.



hi @louis
I think the problem is:

edge-impulse-standalone.wasm 404 (File not found)

also I can’t find .wasm file in my locally…
its weird, since 2 month ago I can run smoothly…

I think I know how to fix this, I have to download manually from

and put the wasm file into public folder.

but still, its weird since 2 or 3 month ago I dont have to download and put manually on the local folder…




1 Like

Hello @desnug1,

Glad that you solved your issue. I don’t see it either a default model in the public folder but I don’t remember if it actually ever existed.
I’ll try to update the of the Github project so it’s clearer in the future how to do so.