Strange error when running flash_windows.bat for Nicla Vision

I tried updating my Nicla Vision firmware using flash_windows.bat and encountered a strange error that references an ESP32 instance

Do I need to downgrade my version of the Arduino CLI?

Hello @ralphjy,

I think there is an issue with your Arduino CLI version or with the Arduino installed packages.
We don’t use anywhere in our platform and tools the ESP32 Heltec boards.

Maybe you can remove this board from your board manager in Arduino IDE (and also the link from the additional boards in your Arduino IDE preferences, I think the Heltec ones are custom boards that need to be manually added). Let me know if that works.



Thanks. There was a problem with the board package that was giving that error. I don’t use Heltec, but it was part of the ESP32 Arduino package. Updating the package made the error go away.

I did have to change the version of the Arduino CLI back to 0.18.3 to flash the firmware.
And apparently the edge-impulse-daemon needed to be updated also (I was running v1.13.12).

1 Like

Hello @ralphjy,

Glad you solved your issue, all the best with your project!