St-b-l475e-iot01a 100Hz accelerometer


i recorded some datasets to train the AI (accelerometer 100Hz). After building the software i downloaded the compiled firmware for my st-b-l475e-iot01a board. But when i tried to run the software i got an stack overflow error. Am i doing something wrong? I think so hole process is working for dataset recorded with 62.5 Hz.


I tried to update the C++ Lib Version in my mbed project. Compiling and flashing showed the same error.

@AssKicker if you change this line:

to read:

static unsigned char repl_stack[8 * 1024];

Does this mitigate the issue? There shouldn’t be something that big be allocated on the stack though, will investigate.

Updating the stacksize helped. But its a little bit curious.

Yep, will investigate.

Underlying issue was that for accelerometer data on this board we were allocating the raw data buffer on the stack (which is 4K), leading to a stack overflow when your window is more than a few seconds. Fix will land in the patch release next week!

Thanks again for reporting @AssKicker!

1 Like

Cool, thanks for the fast support.
And merry Xmas :slight_smile: