Sound sampling failing after update


When I ran the daemon on Windows I got

Edge Impulse serial daemon v1.6.4
WARN: You're running an outdated version of the Edge Impulse CLI tools
      Upgrade via `npm update -g edge-impulse-cli`
Stored token seems invalid, clearing cache...

I ran the npm command to update and after the update it said + edge-impulse-cli@1.7.0 . So I ran the daemon again and it seemed to be working fine.

I am using a Nano 33 BLE Sense and attempted to record multiple 7s duration sound clips. However after a couple of successful recordings, on the next attempt the UI would pop up an error suggesting that it was no longer connected. Also the Terminal wasn’t showing the usual:

[WS ] Incoming sampling request {
  path: '/api/training/data',
  label: 'washing_machine_finish',
  length: 7000,
  interval: 0.0625,
  hmacKey: 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx',
  sensor: 'Built-in microphone'

I have had this in the past, but less frequently and usually refreshing the page in Chrome would fix it.

The only way I could fix it was to disconnect, reconnect, re-run daemon, but again I would only get a couple of recordings before it failed again.

Hi @jasonbsteele, any information in the serial daemon on whether it was disconnected? Or it just stays blank?

Still running but nothing shown after the previous successful sample.

But I have tried again and now I am unable to reproduce. I haven’t changed anything but was able to take 10 recordings consecutively without any issues.

@jasonbsteele, thanks! Intermittent issues are the worst :slight_smile: Will check the logs to see if we can determine what went wrong there.