SiliconLabs Thunderboard

Has anyone got the .bin file to reset the SiliconLabs Thunderboard back to connecting to the Android or IOS App. I want to get mine back to the factory default. Presently using the Arm cloud compiler, but tomorrow I will install the studio and see if that helps. Any idea what the default.bin file is called?

Loving this board.

I have a similar problem. Initially I tried to connect it to the app, it detected the board but didn’t connect. So I flashed the firmware to see if that helps. The firmware wasn’t flashed and I got a fail.txt file on the Silabs board. Now the app doesn’t detect the board and the cli doesn’t either. Let me know if you have a solution

EDIT: managed to get it working with the app but it’s extremely unstable, so it gets disconnected easily.

edit2 - Connects to the EdgeImpulse Studio now, but doesn’t to the app :sweat_smile:

Hi @Rocksetta,

I think the best way would be to build the default firmware using Simplicity Studio:

This way you can go back and forth easily between this one and your Edge Impulse firmware.


1 Like

I faced a similar problem about 5-6 months ago when I got my first Thunderboard Sense (having 5 now)…I even raised an issue for this at the MBED forum…they said its much better to use the Simplicity Studio…and yeah truly Simplicity Studio worked out on that! :slight_smile:

Hey @Rocksetta, were you succesful in compiling the Thunderboard Sense 2 Sensor example on the Arm cloud compiler. I get stuck when it comes to the AMS_CC2_GAS_SENSOR library. Error - No file named mbed_trace.h

What’s your status on this?

Sorry @dhruvsheth my Simplicity Studio software is at school, and I have no preps this semester so remind me during the week and I will try to run it.

1 Like

So I found the .bin reset program as @aurel shows above, I also like the Simplicity Studio but I tried a full install of both NRF-Connect and Simpilicty Studio and almost crashed my old desktop. Anyway, I did find the reset file which I called Thunderboard-default.bin


Hey @dhruvsheth any hints on how to find the source code for the AMS_CC2_GAS_SENSOR. It is always the easy stuff that I have trouble with. :upside_down_face:

I can’t find it in either the simplicity studio or the online cloud. What section is it in?

1 Like

I’m so stuck on it. The Library is either outdated or some changes have been made to it which contradict other versions. I’ll raise an issue in Mbed OS repo on github today. Let’s see what they get back with