Serial port issue with nrf52840 DK

I tried deploying a simple motion recognition module on the nrf52840 DK, but no COM port is detected and the command ‘edge-impulse-run-impulse’ responds with no devices detected.
I need help debugging this issue. where do I start?

You should see the following under device manager (if this is Win 10) like this. Only one of them is available for use with the application. In my case this is the COM14 instance.

ScreenHunter_342 Aug. 13 11.01

Hey, thank you for the response!
Checking the COM ports under device manager was the first thing I did, but no new com ports are detected when the board is connected.
I have already verified that the board and edge impulse setup on my PC are working by flashing different programs on the same board, plus using a different board(NANO 33) for the same impulse project.
I’m really not sure of what I am doing wrong.

Hi @kshitijhiremath,

Just to double check, are you connected to the good USB port and the switch is ON?

You may also need to update the interface firmware, you can follow instructions here:


Hi @aurel thank you for the response.
I have made sure to double checked if it is a good USB port (even on different PCs), and have kept the switch ON for sure.
I am using an externally connected Jlink device to program it and the interface firmware is up-to-date.

There’s no need to connect an external JLink, just connect a USB cable directly to your PC.


The onboard Jlink debugger on my board is not working, it does not get detected no matter what I do.
That’s the reason I was using an external Jlink, can this be a part of the issue?

That may be a hardware issue if the onboard JLink doesn’t show up.
The edge-impulse-run-impulse connects to the board through USB so if you can’t see any COM port it will not work properly. Have you tried contacting Nordic already?


The MCU part of the board works completely fine! I have tried to flash several programs through the external JLink, and the COM port has worked fine so far.
I believed the impulse might have no issues too, since other programs worked.
I will contact Nordic to get some help with the onbord JLink issue too.
Thank you for the help Aurelien!

1 Like