Sample Micro:bit Project not working

I have tried to run the sample Micro:bit project that I downloaded and compiled from GitHub, but it does not work. The LED in the middle lights up and the microphone is also lit up, but no matter how many times I say “microbit” I never see the smiley face. When I open the terminal it also never seems to register the word. Is there something I am doing wrong?

Hi @krobinsonbds Do you actually see microbit go higher on the terminal?

Yes. When I say “microbit” it ranges from .00195 normal volume level to .0137 with a loud voice.

@krobinsonbds I’ve pushed a model update with the model from Micro:bit LIVE with a lot higher sensitivity, can you give it a try? Just pull and rebuild!

Yes, that worked. Thank you very much.

1 Like

Hi Jan, thank you first for making the video on voice activated with Micro:bit board. I have the same issue than @krobinsonbds. How did you do to help him to resolve the issue ? Thanks. Julien

Hi @Juph can you post the output of what you see when you run

edge-impulse-run-impulse --raw

(Or what you see on a serial monitor when you say the word)?

Also, just to confirm, you haven’t changed the word right?

Hi @janjongboom,


I confirm that I have not changed the keyword which is microbit.

Thanks for your help !