Running inference and showing output in web browser

After I create the model I run the command

edge-impulse-run-impulse --debug

and I get the following error, what is this error and how can I fix it?
Screenshot 2023-04-02 164829

I am guessing your Device is running AT command version 1.0.0 is to old.

I am running AT command version 1.8.0.

Rebuild the ready-to-go binary and reprogram your device.

Your EI CLI seems to be up-to-date.

@MMarcial could you please elaborate on what I should do? I don’t understand the meaning of AT command version, and how I can update it or check its current version.

Since the error says the Device is running AT Command Version 1.0.0 I assumed you must re-compile in the Studio.

However, today I think you need to update your computer CLI since the CLI is what is flashing your device (as well as running your Impulse).

Use this to update the CLI:

  • npm update -g edge-impulse-cli

Regarding AT Command Version:

@MMarcial in the documentation it is mentioned that --debug will run a live feed of the camera but when I run

edge-impulse-run-impulse --debug

No web page is opening, how can I run a live feed of my Arduino camera which classifies in real time like in this video at 18:30?

  • The Impulse must be running else you will see:

Do I have to enable something in the project first because I am not getting this address to open? All I am getting is as follows:

Looks like you are running an Audio Model. I think the --debug only works with Vision Models.

1 Like

@MMarcial, first I ran

edge-impulse-daemon --clean

then I entered my email Id and my password, then I selected my project which is “Arduino Nicla Vision - People Counting” which is a visual model. Then it showed this:

After this, I did “CTRL+C” to quit and I ran the following code:

edge-impulse-run-impulse --debug

After that I get the following output:

There is no web address and I am sure I am running a vision model.

You appear to be connecting to a FOMO model based on your project name in the Studio: Arduino Nicla Vision - People Counting.

However, whatever Model is programmed in to the Nicla is a voice or some kind of time series Model based on your screen capture:

The screen capture (see circled text) also indicates you have 3 classes. Are there 3 types of people you are classifying in your Vision Model?

What steps are you executing to get the Arduino Nicla Vision - People Counting firmware onto your Nicla?

To execute the Arduino Nicla Vision - People Counting firmware onto my Nicla Vision I first build the model in edge impulse deployment, which downloaded an Arduino Library which I used in Arduino IDE to compile and upload it to my Nicla Vision (it is working in my Arduino IDE serial monitor but I want live camera feedback). After this, I close my Arduino IDE and then run the edge-impulse-run-impulse command on my command prompt, upon which I get this error message.

This error is indicating the Edge Impulse CLI program edge-impulse-run-impulse does not understand the data streaming out of your Nicla. From within the Studio when you deploy a ready-to-go binary…
…unzip it and then flash the Nicla, then the CLI program edge-impulse-run-impulse can process the Nicla’s output.

So I see 2 solutions for your given hardware:

  • Study the CLI and make your custom Ardy program output data compatible with the CLI program edge-impulse-run-impulse.
  • Go into the EI Studio and use the Data Acquisition page or the Live Classification page to see what the Nicla camera is seeing.
1 Like

Got it thanks, its working now. Thanks a lot for all the help @MMarcial :slight_smile: