Running Impulse Locally on Arduino Nano 33 BLE Sense

Hi. I am trying to run my impulse locally on the arduino nano 33 ble sense using this instruction and using this tutorial to flash to the board, which was successful but I couldn’t see any serial output. I built the firmware from edge impulse as a C++ library and flashed the board following the tutorials linked above. My aim is to run the impulse on the board using the zephyr method rather than arduino method. How can I see the serial output when running impulse locally on arduino nano 33 ble sense using zephyr?

  • zephyr Version: 2.6.99
  • edge-impulse-daemon Version: 1.13.15
  • arduino-cli Version: 0.13.0 Commit: 693a045
  • OS: Pop!_OS 20.04 LTS x86_64

Hello @yusuf,

You can use whatever Serial monitor you are familiar with (PuTTY, Arduino Serial Console, Screen).
I’m also pretty sure we have integrated a Serial Monitor command in our CLI but I cannot find which exact command is it. Asking internally and will keep you posted :slight_smile:

Regards,

2 Likes

Ok got it, the Edge Impulse CLI command to see the console output is:

edge-impulse-run-impulse --raw

Regards,

Louis

3 Likes

Thank you very much @louis, I have tried viewing the console output via moserial serial monitor on Linux and also tried the Edge Impulse CLI command to see the console output, and didn’t get anything. That is why I asked here to see if there is something else I missed.

@yusuf,

Can you first try the samples/basic/blinky firmware mentioned in your previous post and see if you get serial output.
If not can you check whether the firmware is configured to output over TX/RX Pin 1.03/Pin 1.10, respectively.

// Raul

1 Like