Running ESP32 Firmware on AIThinker ESP32-CAM


First of all, thanks for the release of the official ESP32 firmware.
I have tried compiling (with a few modifications as suggested in the README) and running the firmware on an ESP32-CAM. It worked, but I can’t use the edge-impulse-daemon with my ESP32 device. Here are the full logs from the daemon:

[SER] Connecting to /dev/tty.usbserial-1420
[SER] Serial is connected, trying to read config...
[SER] Unhandled configuration option snapshot ===== inference ====== 
[SER] Unhandled configuration option snapshot sensor 1
[SER] Unhandled configuration option snapshot model type classification
[SER] Retrieved configuration
[SER] Device is running AT command version 1.7.0
[SER] Unsupported AT command version running on this device. Supported version is 1.6.x and lower, but found 1.7.0.
[SER] Update the Edge Impulse CLI tools (via `npm update edge-impulse-cli -g`) to continue.

I have the latest version of the CLI (from GitHub) installed. Is there anything that I can do to make it work or should I wait for the next edge-impulse-cli release?


Hello @alwin_wint3r ,

Have you made other changes apart from changing this line firmware-espressif-esp32/ei_camera.h at main · edgeimpulse/firmware-espressif-esp32 · GitHub

with that line:


And recompile the firmware. On my side, it worked pretty well (I tried last week):

Let me know if that works for you. If not I’ll ask @AIWintermuteAI to have a look.



What does edge-impulse-daemon --version show for you?

Hi @louis

I tried to compile the firmware from GitHub using IDF, but I’m having this error.

I’m using the Windows OS.

Hello @TronixLabPH,

I have not tried to use IDF on Windows. @AIWintermuteAI any idea?



No. I recommend using Linux/MacOS for building firmware. C/C++ programming is too much pain on Win. Using Virtual Machine or WSL are other valid options.

1 Like

Thanks @louis for your response and initiative. :handshake:

It’s now clear to me. :clap: Thank you, @AIWintermuteAI

Hello @louis and @AIWintermuteAI

Sorry for the super late reply, I got busy with something else.

I got it working by updating the edge-impulse-cli to 1.15.1.

Thank you