RP2040Connect can no longer connecto EdgeIMpulse/ cant reupload firmware either

HI, I just gpt the RP2040Connect and was trying to do a simple audio ML program.
First issue was Edge Impulse wasn’t detecting the microphone. I kept getting flat lines. So I ran a simple arduino program to make sure the microphone worked and it did. Then I no longer had connection to the rp2040 from Edge-impulse . I unplugged /plugged the board back in and could no longer upload sketches. The ACM port was no longer detected. so I reran the port_install.sh script again adn sketches work again, but I still can’t get edge-impulse t connect to the RP2040. I can’t even get my RP2040 to go to the USB mass media mode again to re-upload the firmware.

I have no idea what I did wrong or how to fix.
I was following this tutorial for the simple audio tutorial https://www.youtube.com/watch?v=HWkVpm_ldeU

Hi @gman9500,

I unplugged /plugged the board back in and could no longer upload sketches

This part sounds like there is an issue with the USB connection or with the RP2040 Connect. I recommend first trying a different USB port and/or different USB cable. If that does not work, please try some of the fixes in these threads: