Resizing Dataset Frequency

Hi guys!

I have made two dataset with “edge-impulse-data-forwarder”. One of them using just an accelerometer and the other using accelerometer + gyroscope.

I’m trying to mix them up with the “Uploader” and just selecting accelerometer “Input axes” when “Creating Impulse” but when I try to generate the features I got an error that are “expecting more columns”. I think It could be due to the frequency.

Is there a possibility to “resize” the dataset (is about 2000 .json files)? Should I remove some columns?
Is there a simple way to do that?

Thank you in advance! :smiley:

Hi @juacuegut,

If your 2 datasets have very similar frequencies (ie 1 Hz difference), it’s worth patching the json files.
You can align the interval_ms parameter for all your files before uploading them.

One alternative and longer method is to recapture samples with the data-forwarder and force the sampling frequency:

edge-impulse-data-forwarder --frequency 100


@jaucuegut, if this is about project ID 11565 I guess you’ve figured it out, but all data that you feed into the Processing Block needs to have the same sensor axes. If you have both accelerometer and acc+gyro data in your dataset this will thus lead to an error. You can unselect the gyro axes in the Create impulse screen to get around it, or only include data with both acc+gyro data (which seems like what you’ve done).