Raspi 4 Bullseye can't find camera

Hey there,

i want to use the Pi for object detection. I already followed the instructions and installed the needed dependencies. I also connected the Pi to edge impulse but then the problem occurs: the camera (raspberry camera v2.1) can’t be found. The OS is Bullseye. What could i do?

I already tried to fix this problem with the newest version of ‘Buster’, but there i have problems to connect to edge impulse.

Thanks in advance.

Greetings from germany

Hi @HTWG_Elite,

There are some changes in the camera source management with Debian Bullseye.
Can you download this new gstreamer.js file, and copy it on the Raspberry Pi in: /usr/lib/node_modules/edge-impulse-linux/build/library/sensors/ (use sudo cp)?
This patch should work and we’ll work on a proper fix with our engineering team.


Hi @aurel,
Thank you for the fast reply. Copying the gstreamer.js file worked for us, thanks for the help.


Hi, we’ve pushed v1.3.0 of the Edge Impulse for Linux tools which fixes this issue. You can update via:

sudo npm update -g edge-impulse-linux