Raspberry pi pico: audio sampling rate 32000 Hz, not working

I have trained a binary classification model on edge impulse that classifies alarm and noise. I am deploying it on Raspberry pi pico. Initially I used the sampling rate of 16 kHz, 1 s of samples and deployed it on pico using C++ library and it worked fine just has a little latency.
Now when I tried to do the same with 2s of data samples, the sampling frequency is changed to 32 kHz. I made the build with C++ library as I did previously but now I cannot open the usb port (as in serial port) to see anything for debugging, nor does the model seems to run on its own.

P.S I am using Analog microphone MAX9814 for capturing audio samples.

P.P.S the same model (32 kHz sampling rate) works fine on Arduino NANO BLE Sense, using its onboard microphone. Does the problem has something to do with pico and its sampling rate?
If someone can please look into this? @shawn_edgeimpulse?

Welcome to the forum @nh2007

Can you share your project id?

We had a member with a microphone and pi pico issue recently if you haven’t seen it let me link it here:



Hi Eoin,
Thank you for responding. The project ID is 162095.

I have seen that issue and it will be relatable later on when I will be adding pdm microphone with pico.

Currently, I am using analoge microphone on A0 (26) of pico. The problem I am facing is that when I design the impulse with sampling frequency of 32 kHz, it does not run on my pico. Is it something to do with (i don’t know how to put it :sweat_smile:) sampling rate ability of pico?

if this could help Sound-Activated Kitchen LED Control System Using Raspberry Pico Edge Impulse and Home Assistant | by Ferry Djaja | Mar, 2023 | Medium.

1 Like

Thank you for pointing me towards this, I will look into it.