Raspberry pi 4 and edge impulse

**Question/Issue:I am currently working on an object detection project with FOMO and Raspberry Pi. I have the model and have successfully connected my Raspi with Edge Impulse using “edge-impulse-linux”. After testing the project, the next step is deployment. However, when I tried typing the command “edge-impulse-linux-runner”, I encountered an error. I searched for solutions and tried several options, such as typing the command “edge-impulse-linux-runner --force-target runner-linux-aarch64”. Unfortunately, I still received an error, which can be seen in the picture .

node --version

raspi os : Raspbian GNU/Linux 11

getconf LONG_BIT

uname -m

**Project ID:214513

Context/Use case:**

Hi @OumaimaHassani

It looks like the model downloaded but then the file cannot be found.

Can you try running the impulse with your project key, does it give the same error?

Dashboard > Keys > Api Key

edge-impulse-linux-runner --api-key (Api Key e.g. ei_1234…)



Hello! Thank you very much for your response. Yesterday, while scrolling through similar errors, I thought that I needed to install a 64-bit operating system. After reinstalling the OS and connecting the Raspi with Edge Impulse, this is the error that I am currently encounterin when attempting to deploy the model

Hi @OumaimaHassani

Did you verify that the ribbon cable camera is connected properly?

Run this please and paste the output:
edge-impulse-linux --verbose

If the camera is verified to be connected, then try following the install steps here being careful to apply the correct permissions:



Thank you very much. I will try this and see if it works.

Thanks again.

this is the output


Hi @OumaimaHassani

The camera appears to be there, you can try:
edge-impulse-linux --clean

This will get you a new connection to studio. If this deosn’t work you will need to reinstall the CLI as a step was likely missed:

You can try to do this quickly via:

cd ~/.npm-global/lib/node_modules
rm -rf edge-impulse-cli
npm install -g edge-impulse-cli

However you may need to go back to the beginning and follow the steps:



1 Like

Okay, thank you. I will try this out and provide you with feedback once I see if it works.

Thank you very much for your help. it is now working.

1 Like