QR code for phone

Hi all,
first time user here. Trying to connect phone from my Edge Impulse 1st project by clicking “connect a new device” then clicking on “use your mobile phone” but no QR codes popping up. Tried it from Mac and Windows same results, logged out and in several times, same outcome. What am I doing wrong, any advise would be great!
Thanks,
Abe

Hi @teledoc, do you have an ad blocker that might interfere? Is there any error logged in the browser console?

Alternative you can grab an API key from Dashboard > Keys and then visit: https://smartphone.edgeimpulse.com/?apiKey=ei_

(replace ei_... with your api key)

No popup Jon, actually a lot of functionalities are not working for me, for example upload samples through collect data is not working either. I used the link you sent me but it only allow caputring images, I am trying to upload sound. I am using cli uploader and was able to upload a .wav file, will see how that goes. Thanks for your help!
Ab

Hi @teledoc, after you connect on your mobile phone you can sample data from the Data acquisition window (your device should be listed under ‘Record new data’), but based on your report I think the client is not loaded. I suspect an ad blocker or a PiHole or something similar. It’d be helpful if you could post your browser console logs. See https://balsamiq.com/support/faqs/browserconsole/ .

Attached are the errors I am getting on Chrome, explorer also is no go, whenever I click on any button or feature I am just not getting any response.

However I tried firefox today and it worked, so will use it to and let you know how it goes, thanks.

@teledoc, that’s definitely being blocked by an adblocker or content blocker.

Whatever is blocking it is on both Chrome and IE/Edge and on all my machines, Linux, Windows and Macs. However on Firefox it works smoothly without a hitch again on all 3 machines. This tells me it has to do with the browser compatibility as I have them on the lowest security setting and popup blocker allowed for EdgeImpulse. I wonder if anyone else is having this issue? looking forward to some resolution. Thanks for your help Jon!! Ab

@teledoc, not sure… Are you running a PiHole in your network, or using uBlock or AdBlock Plus in Chrome? We have a patch that will hopefully work around this which will be out later this week, but hard to verify on our end! :slight_smile:

Yes! it was uBlock, removed it and problem solved.
I didnt even know I had such an extension, great job.
thanks Jon!

1 Like