Pi Pico 2040 Serial Issues

I have a brand new Pi Pico.

Flashed with rp2-pico-20220117-v1.18.uf2 from: MicroPython - Python for microcontrollers
I get a Com5 USB\VID_2E8A&PID_0005&MI_00\7&381503f8&0&0000 in Zadig showing as Board CDC (Interface 0) using usbser (v10.0.19041.1202) and putty gives me a connection and a python prompt - so the board and the usb / serial connection can work.

Flashing with ei_rp2040_firmware.uf2 from https://docs.edgeimpulse.com/docs/development-boards/raspberry-pi-rp2040
I get a Com4 USB\VID_2E8A&PID_000A&MI_00\7&207451d&0&0000 in Zadig showing as Board CDC (Interface 0) using usber (V1.0.0.0) and putty does not connect on Com4 – it just hangs and I have to unplug the pico to get Putty to release the port.

Trying to update the driver using Zadig 2.7 says it was successful but has no effect, even after a reboot still shows as v1.0.0.0 and putty still hangs,

Replacing the driver with winusb, and then back to USB Serial (CDC) it still goes back to v1.0.0.0

Finally in Device Manager, using “Update Driver” and Browse I managed to get the version up to v10.0.19041.1202 – but still no putty connection

I also tried a Chrome “Connect using WebUSB”, which shows a ‘Board CDC (Com 4) - paired’, but I get a “Failed to connect to device” error straight away or sometime Chrome just hanging and not doing anything.

I have also tried on a different windows machine, and I still get no putty connection.

Any help appreciated please!

Thanks very much

Hi @KevWal,

This seems to be an issue with the Pico at the moment–thanks for letting us know. I have filed an issue on the firmware page, which you can track here: Serial comms hang in Win10 · Issue #1 · edgeimpulse/firmware-pi-rp2040 · GitHub