PI 4 with pi-Cam V2 setup issue

Hello, I’m getting the below error when running “edge-impulse-linux --disable-microphone” command on a Raspberry PI 4 with connected PI Camera V2,

pi@pi4:~ $ edge-impulse-linux --disable-microphone
Edge Impulse Linux client v1.2.11
Failed to initialize linux tool Error code was not 0: Probing devices…
[0:10:44.480782972] [998] INFO Camera camera_manager.cpp:293 libcamera v0.0.0+3156-f4070274
Failed to start device monitor!

I tested the camera with the below command and got the expected 5 seconds live stream on the terminal,
pi@pi4:~ $ libcamera-hello

I use PI4 in headless mode and went trough all suggested steps in the below link,

Any idea how could I fix this issue.
Thanks.

Have you tried to reinstall the gstreamer packages? Here is the repository with the instructiones to install: https://github.com/PhysicsX/Gstreamer-on-embedded-devices

Thank you Isaac, after Gstreamer installation, I couldn’t run the suggested Hello World test application on my setup. I’ll try fixing those issues and let you know the results.

I managed to reinstall the Gstreamer package but still the same error.

Problem solved by switching to the older version of OS “Buster”, instead of the latest one “Bullseye”.

which version of buster do you use? with the newest version of buster we arent able to connect to edge impulse with the command ‘edge-impulse-linux’.

I used the one in the below link:

https://downloads.raspberrypi.org/raspios_armhf/images/raspios_armhf-2021-05-28/

Hi, we’re investigating this issue. There’s a change in how gstreamer video sources work in Bullseye, and trying to pin down exactly what we need to fix on our end.

Hi, we’ve pushed v1.3.0 of the Edge Impulse for Linux tools which fixes this issue. You can update via:

sudo npm update -g edge-impulse-linux

:partying_face: