NPM error for installing dependencies on Raspberry Pi 4

I ran into a few errors related to npm when I installed dependencies on a brand-new Raspberry Pi 4 by following steps on “Raspberry Pi 4 - Edge Impulse Documentation”.

  • First, the installation for nodejs does not trigger a npm installation automatically, which is needed on the later part of this script. (I fixed it by manually install npm via “sudo apt install npm”)
  • Second, the “npm config set user root” is outdated. “user” is not a valid key for npm config any more.
  • Third, I got quiet a few warnings from npm when I install edge-impulse-linux as the last part of this script, which should be fixed.

Overall the script works fine for me. I recommend to fix the npm issues to improve the user experience.

1 Like

Hi @Daniel1247

Thanks for sharing your experience, and welcome to the forum.

We welcome all comments and value suggestions as it can help us improve the experience for new users. Please keep up the experience updates, feel free to message here in the same post as a journey or post new suggestions.