Nicla Vision: "ERR: Failed to get snapshot"

Hi, I have created a project for the classification of two objects using Arduino Nicla Vision.
In the Deployment phase, I selected “Arduino Library,” and the output was successful (unlike with Open MV, where the output failed due to memory issues).
I loaded the library into the Arduino IDE and selected the example for image acquisition with Nicla Vision for the classification of my objects.

Initially, the sketch compiled successfully, and I obtained the classification of my objects. However, upon retrying, I encountered issues (always with the same project). After uploading to the Arduino IDE, the output shows:

While in the serial monitor, I see:
immagine
Could you tell me why it worked fine initially but later I encountered these errors? What could be the reason for this? Thank you.

Project ID 357052

Hi @Anna_Marino,

The “Invalid DFU suffix signature” looks like a warning that you can ignore for now.

ERR: Failed to get snapshot (-1) looks like a problem with the Nicla Vision not being able to communicate with the onboard camera. Could you try running Examples > Camera > CameraCaptureRawBytes and see if you encounter the same error?

Edit: the error won’t have the text if you run the above example. You should see raw bytes appear on the serial monitor. If there is an error, the LED will blink rapidly.

1 Like

Hii, I am suffering from the same problem, and also the LED, as you said, flashes quickly for one second immediately after turning on and then turns off, and no outputs appear in the Serial monitor. Can you help me? @shawn_edgeimpulse
For your information, I use a portenta H7 device.

Hi @eng771.ruqaya.alaa,

Did you try running Examples > Camera > CameraCaptureRawBytes? If so, what did you see in the Serial monitor?

hi, i toke same fault and change cable it solved

1 Like