June 2021 Edge-Impulse -Cli installation Issues

Anyone getting any recent errors (June 22, 2021) installing the Edge Impulse Client?

was compiled against a different Node.js version using
NODE_MODULE_VERSION 72. This version of Node.js requires
NODE_MODULE_VERSION 88. Please try re-compiling or re-installing
the module (for instance, using `npm rebuild` or `npm install`).

Getting it for Node version 14. and a recent node version 15.10.0

Any suggestions?

Solved it by installing the most current Node at https://nodejs.org/en/download/current/



Now getting errors on flash_windows.bat that say

If you see a ModuleNotFoundError error, run the following commands to add Python packages
     python -m pip install pyserial>=3.4
     python -m pip install inquirer>=2.7.0

but of course those don’t install. I updated windows Python but still no luck. Any suggestions?

Hi @Rocksetta,

Can you provide the full output when running the bat script?

On the Node issue, Node 14 is the recommended version as it’s the LTS version. I would suggest trying this withe Node 14:

npm uninstall -g edge-impulse-cli --force
npm install -g edge-impulse-cli

This should force the bindings module to recompile from sources.


1 Like

@Rocksetta After updating Node.js you’ll need to reinstall / upgrade the CLI as it has a binary component that needs to be recompiled.

1 Like

@aurel Does edge-impulse-cli have a way to print the version number?

I often use the following for testing installations:

arduino-cli version
node -v
npm -v

west --version
mbed-cli --version
make --version
arm-none-eabi-gcc --version
python --version


The Linux tools have a version flag, will make sure we add it to the rest of the CLI tools. Version is printed when you first launch the daemon or uploader though:

$ edge-impulse-daemon
Edge Impulse serial daemon v1.13.6

edit: This will be fixed in CLI version 1.13.8.

1 Like