Issues with CLI

running the npm install -g edge impulse cli give this error.

npm WARN deprecated @zeit/dockerignore@0.0.5: “@zeit/dockerignore” is no longer maintained
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated request-promise@4.2.6: request-promise has been deprecated because it extends the now deprecated request package, see https://github.com/request/request/issues/3142
npm WARN deprecated har-validator@5.1.5: this library is no longer supported.

And running the edge-impulse-daemon give this error

Error: Could not locate the bindings file. Tried:

I tried the suggested solutions, uninstalling or reinstalling but it still doesnt want to work.
Tried both on linux and widnows 10.
any suggestions ?

Can you give us the log when you run npm install -g edge-impulse-cli ?

I figured out how to solve it, or it did happen. :blush:
I deleted the npm folder and npm-cashe in C:\users\Your Name\AppData\Roaming\npm
Then i ran again npm install -g edge-impulse-cli
Now its working

Thank you

2 Likes