Installing problems

Hello, I am new edge impulse user.
I downloaded the firmware to my desktop, and try to run flash_windows.bat script on Windows10.
But the script kept generating these errors.
Thanks in advance.

Hi @WildForest,

Some users had similar issues in the past: Could not find a valid build artifact [SOLVED]
Could you check that the bin firmware is in the same folder as the flashing script?


Great !! Thank you very much, Aurelien.
I have appreciated and apparently solved my first problem.
In fact, I noticed that the flashing of my Arduino33sense was about half of what is shown in
Jan Jongboom’s video tutorial (280kbytes in only 69 pages instead of 525kbytes in 129 pages).

Why ?

Also, unfortunately I run into another error trying to complete last step of the installation (called 3. Setting keys)
This is the screenshot of the terminal after typing edge-impulse-daemon

‘edge-impulse-daemon’ is not recognized as an internal or external command, executable program or batch file.
Where is my mistake?
Thanks again, Fernando

Hi Fernando,

The size of the firmware may be different depending on your project’s configuration and sensor type (ie: audio usually takes more memory space than accelerometer).

Have you installed the edge-impulse-cli yet?


OK Aurelien.
As suggested, I reinstalled Edge Impulse CLI disabling the antivirus of my computer because I had problems with the installation of Node.js (the reason for the conflict between Norton and Node I do not know).
Now, after typing ‘edge-impulse-daemon’ on terminal promt:

What’s wrong?
Sorry for this never ending story,

Hi Aurelien,
after change position of Python3.9 folder, consulting solutions reported here and after typing these commands:
npm uninstall -g edge-impulse-cli
npm install -g edge-impulse-cli
I have:

thanks for any suggestions,

Hi Fernando,

You can force overwirting existing files. You can run:

npm uninstall -g edge-impulse-cli
npm install -g edge-impulse-cli --force


Thank you Aurelien,
this the result:


It looks like python is not in your path.
Can you run python or python3 from the command line?

You can also install everything you need via chocolatey for Windows, using the scripts here:


Dear Jenny and Aurelien,
many thanks for your kind attention.
As soon as I can I’ll try to follow Jenny’s suggestion.
While waiting for your reply, I tried to click on the “connect via WebUSB” button presents on ‘DataAcquisition’ and, may be, in ‘Devices’ too. And after selecting the target device, … everything seems to work !! :open_mouth:
I don’t know for what strange reason, but I am happy that EdegeImpuse works so well.
I tried a very basic, simple Audio classifier and, after flashing Arduino, it seems to run very well.
Thanks again.
I will write you the result of the installation via Chocolatey for Win.
Fernando :slight_smile: