Himax WE-I; Trouble in updating bootloader

Hi Guys

I wanted to update the Himax WE-I bootloader from 1.4.2 to 1.4.4 so I can flash an application with two .img files. I did it based on this procedure:

I installed FTDI driver and Created the .rules file and then tried to update the bootloader but it only erased the 1.4.2 version and didn’t install the 1.4.4 version. It says “No available port”. Now the device doesn’t have any bootloader and I can’t do anything. I have another himax we-i and I did the same procedure and a same thing happened again.

If you know what is the problem, please help me.


Can you ensure there is no serial terminal connect to HIMAX WE1 EVB.

Otherwise can you try sudo udevadm control --reload-rules to reload the udev rules.

If the above doesn’t work can you share the output of the following commands.

  1. lsusb
    First plug your Himax board then run lsusb. You should get something similar too.
Bus 001 Device 093: ID 0403:6015 Future Technology Devices International, Ltd Bridge(I2C/SPI/UART/FIFO)
Bus 001 Device 092: ID 0403:601c Future Technology Devices International, Ltd FT4222
Bus 001 Device 031: ID 04b4:6570 Cypress Semiconductor Corp. Unprogrammed CY7C65632/34 hub HX2VL

  1. groups
1 Like

Hello @mrastikerdar,

I just tried on my side and I had the same issue (thanks @rjames and @mateusz for helping me finding the issue).

To fix it, I had to run the following command using sudo:

sudo ./WE-I_ISP_Tool himax_we1_bootloader_v1_4_4.bin

Let me know if it fixes it on your side.



1 Like

Hi @louis, thanks a lot, it worked with sudo.

thank @rjames for your reply