Himax WE-I Plus ~ Timeout when waiting for > (timeout:5000) onConnected


Read similar posts but can’t seem to fix the issue using the recommended solutions.
I get this error for the Himax WE-I Plus board

Edge Impulse serial daemon v1.16.0
Websocket: wss://remote-mgmt.edgeimpulse.com
API: https://studio.edgeimpulse.com
Ingestion: https://ingestion.edgeimpulse.com

? Which device do you want to connect to? COM3 (FTDI)
[SER] Connecting to COM3
[SER] Serial is connected, trying to read config…
[SER] Failed to get info off device Timeout when waiting for > (timeout: 5000) onConnected`

I have flashed the edge impulse firmware using the .bat script, and this succeeded.
The bootloader is the latest version (v1.4.4) and the Edge Impulse Device SDK is also visible so flashing the board did not fail i.m.o. Also, I did a reset after flashing on the board because I read that’s also a known issue.

What can I do next to fix this issue of not connecting?


Hello @yannick1203,

If you cannot connect with the CLI, you can by pass it and just run AT commands from the terminal.

Here’s a full list of the Serial Commands available: Serial protocol - Edge Impulse API




Yes, best to see if the AT commands work typing them in manully using TeraTerm. For me it both works on MAC and Windows. The only difference I see with my board is the bootloader version.

I have a similar problem with the same Himax WE1 board.
The firmware update process works well, but once I launch edge-impulse-daemon the system quite correctly first asks my user ID and password, but after them id ends up in eternal timeout loop. I am attaching a screenshot thereof.
I tried the serial port (AT-commands) alternative as well. Once I hit the reset button there is a nice list of system parameters showing up, clearly indicating that the COM port parameters are correct. BUT no matter what I type (AT+HELP in the attached screenshot) there is never any response from the Himax WE1 card. So… this option doesn’t work either.
I have tried both options with two WE1 cards and they both work the same way… or don’t work, to be precise. Any advice apart from upgrading the bootloader from 1.4.2 to 1.4.4 (which is not possible as I do not have a Linux PC.

Okay, there is a limitation with the number of attachments… I’ll attach the bootloader message screenshot to another reply

Here is my second attachment