Himax WE-I Plus [SER] Failed to get info off device Timeout when waiting for > (timeout: 5000) onConnected


I am trying to connect my Himax board to edge impulse and have not been able to run the daemon. When I try to run it, the timeout: 5000 is raised. When I press reset as it is attempting to retry, the timeout error is timeout: 2000 instead.

I have been attempting to troubleshoot with the responses of similar posts, the response above the timeout is when the command edge-impulse-run-impulse --raw is run.

I have updated the firmware and that process goes smoothly. The WebUSB connection also is not working due to timeout issues.

Thank you for the help.

EDIT: I have tried running the AT commands and I get no response to any AT+ command even after waiting several minutes.

I have tried running the edge-impulse-deamon --clean and pressing reset once it was retrying. It seemed to go further in the initialization, but there was still an error as seen below.

Hi @gtceribelli

Welcome to the forum!

  1. Firmware Update: Confirm that the firmware on your Himax WE-I Plus board is up to date. If not, update it to the latest version of our firmware: Himax WE-I Plus | Edge Impulse Documentation
  2. Retry Initialization: If you’re using the Edge Impulse CLI (edge-impulse-deamon), try running it again with the --clean flag to ensure a fresh start. If there was progress after pressing reset during retry, it indicates that the board is responsive to some extent.
  3. AT Commands: Since you mentioned that you’re not getting any response to AT commands, double-check the communication settings (baud rate, port, etc.) and ensure that the correct port is selected. Make sure that the serial connection is established properly between your computer and the board.
  4. WebUSB Connection: If you’re encountering timeouts with the WebUSB connection, try using a different USB cable or USB port on your computer. Sometimes, USB communication issues can be caused by hardware problems. Follow here for WebUSB: Data acquisition | Edge Impulse Documentation



1 Like

Hey Eoin!
Thank you for the help. I tried to run the edge-impulse-daemon --clean again and was able to get farther by continuously pressing reset at every step. It was able to get farther but I don’t seem to be able to get farther than the read API key with the error (image of command window is attatched):

Cannot connect to remote management API using daemon, failed to read apiKey, deviceId or deviceType from device. Restarting your development board might help. Retrying in 5 seconds…

Is this issue on the device side or on the server side? I am just wondering if you have an easy fix before I go into a thousand rabbit holes trying to fix an easy problem.

Thank you for the help!

OK so you must have an incorrect api key or password, just log into the project and copy the api key then use it directly instead of the password:

Project>Dashboard>apikey> copy the ei-xxxxxxxx

Run with the api key:
edge-impulse-daemon --api-key "ei-XXXXXXXXXX"