Help with error when running on PI

I was wondering if someone could help with an error I get when attempting to run my model on a Pi Zero for the first time

I’ve previously created my model using a Pi 3b, and ran successfully.

I’m setting up the PI Zero W for the first time, with a fresh install of Pi OS, all updates done, and the Python SDK installed using docs from the edge impulse website, here

Node.js isn’t installed on the PI Zero as Edge Impulse requires v12 which isn’t available on ARM6 / Pi Zero, but I don’t think it’s necessary to run the model

Here’s the error from the Pi Zero terminal window…

pi@pizerow:~/Documents $ python3 model.eim 11
Traceback (most recent call last):
  File "", line 66, in <module>
  File "", line 44, in main
    model_info = runner.init()
  File "/home/pi/.local/lib/python3.7/site-packages/edge_impulse_linux/", line 132, in init
    model_info = super(AudioImpulseRunner, self).init()
  File "/home/pi/.local/lib/python3.7/site-packages/edge_impulse_linux/", line 26, in init
    raise Exception('Model file "' + self._model_path + '" is not executable')
Exception: Model file "/home/pi/Documents/model.eim" is not executable
pi@pizerow:~/Documents $ 

Any help would be appreciated. Note I’ve tried changing the audio device to 1 instead of 11 in the arguments for but no change

UPDATE: I’ve altered the file permissions on model.eim to ‘anyone’ and now when I run classify,py again from the terminal, it just hangs and does nothing at all, not returning me to the command prompt?

I noted that during this ‘hang’ CPU utilisation = 1%, RAM = 50%

Hi @Spectrum48K,

It looks like your downloaded model doesn’t have correct permissions.

Can you run:
chmod +x /home/pi/Documents/model.eim

and try again?


thank you - I’ve fixed the file permission error


Now, when I try to run, in the terminal window, it just hangs and does nothing - no on screen response at all and I’m not returned to the command prompt

Has anyone successfully run on a PI Zero W? Note, the same code and model run fine on my Pi 3b

@Spectrum48K So we’re building Armv7 / Armv8 models, and the Pi Zero W is an Armv6 device - so I doubt that this works. You can do a quick test by running:

./model.eim stdin

Then typing