Grove-vision-ai build failed

I followed the tutorial on github to build the firmware for my grove vision ai module but failed. I tried both docker way and natvie lib way. and they both raised the same issue. Copying it below:

In file included from ./app/scenario_app/edge_impulse_visionai/ei-model/edge-impulse-sdk/classifier/ei_fill_result_struct.h:25,
                 from ./app/scenario_app/edge_impulse_visionai/ei-model/edge-impulse-sdk/classifier/inferencing_engines/tflite_eon.h:26,
                 from ./app/scenario_app/edge_impulse_visionai/ei-model/edge-impulse-sdk/classifier/ei_run_classifier.h:41,
                 from app/scenario_app/edge_impulse_visionai/inference/ei_run_camera_impulse.cpp:20:
./app/scenario_app/edge_impulse_visionai/ei-model/model-parameters/model_variables.h:74:1: error: 'const ei_learning_block_config_tflite_graph_t' has no non-static data member named 'quantized'
   74 | };

I also tried compiling edge_impulse_sensecap, same error

I’m working on a ubuntu 20.04 host machine. Setup for build env is pretty straightforward following the README so I don’t think it’s my setup issue. Please advise.
Project ID:

Context/Use case:
I need to learn how to fetch raw data from the IMU and camera from the chip. So I want to understand the firmware you provided.


It looks like you may have corrupted your model. Can you

  1. remove tflite-model, model-paramaters and edge-impulse-sdk.
  2. Re-export your model from Studio.
  3. unzip the contents to replace the above directories.
  4. build

// Raul

1 Like

Hi Raul,

thanks for your reply. what do you mean by re-export model from studio? i never imported any more. I directly compile it after a git clone? is there any model I need to download manually? I didn’t see relevant tutorial on github readme. Thanks


  • Follow this tutorial
  • RE: re-export the Model
    • At Step 2.1 use the Studio to Deployment page to deploy (export) your Impulse:
      • This export will be a *.uf2 file.
  • …continue with the tutorial
1 Like


On further inspection it looks like our latest update to the firmware repo broke the build.
edge_impulse_firmware/edge-impulse-sdk was updated while edge_impulse_sensecap/edge-impulse-sdk and edge_impulse_visionai/edge-impulse-sdk were not.

I’ve fixed it now and updated the project. Please pull in the latest changes and try again.

1 Like

yeah i realized it is a code issue. I commented out the quantized field and another field, it started working. But it’s good you fixed it. Thanks!


Allthough it may have build for you successfully, the model/project is in a inconsistent state. I’d suggest you pull the latest changes from the repo and rebuild.

If you’d like to try another model (other than the default in the repo) follow the steps in the Source Code Organization section of the README